Reply
CJJE
by Visitor 4 Posts
on March 2007
7 Replies - 9842 Views

VAIO Control Center Broken!!

My Vaio FE41Z came with Vista installed, and the VAIO Control Center used to let me control features on the laptop. Yesterday I found the program would not operate generating instead a Microsoft Visual C++ Runtime Library message saying "Run Time Error. This application has requested the Runtime to terminate it in an unusual way."

Has a recent Vista update stopped it working??

I also now find that the wireless device switch window only lets you select 2.4GHz or 5GHz LAN operation - it used to also turn the bluetooth on or off. Now Bluetooth is on whenever the WiFi is on (and presumably eating battery power!).

Any solutions please??

Chris

Reply
0 Kudos
Blencogo
Expert 11,267 Posts

Re: VAIO Control Center Broken!!

Hi Chris and welcome to Club Vaio,

Another great mystery!!!!

All I can suggest is to download and reinstall the Vaio Control Centre from FE31Z VISTA DOWNLOADS

:smileyconfused:

Reply
0 Kudos
CJJE
Visitor 4 Posts

Re: VAIO Control Center Broken!!

Thanks Blencogo,

But your link is to the FE31Z and not my FE41Z. Also, when trying to load that page IE7 reports errors on the page & it doesn't appear.

The FE41Z download page gives the pre-installed utilities, but as a single massive file. Should I download that? It also refers me to my C:/Utils folder which holds all these files - but my hard drive doesn't show this folder (even after enabling hidden files).

Should I have back-up copies of these pre-installed files somewhere on my laptop??

Chris

Reply
0 Kudos
Blencogo
Expert 11,267 Posts

Re: VAIO Control Center Broken!!

Hi Chris,

I have to admit ignorance on where Vista keeps the Utilities files - XP stores them in C:\Utils. May be worth searching C:\ for Utils.exe.

The reason for pointing you at the FE31Z was because that model has the individual file available for Vista for the Vaio Control Centre.

I'm sure it will be in the FE41Z Preinstalled Utilities but I'm not sure where.

:smileyconfused:

Reply
0 Kudos
CJJE
Visitor 4 Posts

Re: VAIO Control Center Broken!!

Thanks again,

I've installed the program from the FE31 page, (and verified it has replaced the original version on the hard disk) but it still fails in exactly the same way.

Does it use MS SQL Server 2005? I was "given" the SQL Server SP2 last night. Has this added new security hooks that mucks up the Sony program? (I've tried removing that, and reistalling, but at still SP2. Didn#t make VAIO Control Center work tho'

Chris

Reply
0 Kudos
dennisgodderie
Visitor 8 Posts

Re: VAIO Control Center Broken!!

Thanks again,

I've installed the program from the FE31 page, (and verified it has replaced the original version on the hard disk) but it still fails in exactly the same way.

Does it use MS SQL Server 2005? I was "given" the SQL Server SP2 last night. Has this added new security hooks that mucks up the Sony program? (I've tried removing that, and reistalling, but at still SP2. Didn#t make VAIO Control Center work tho'

Chris



I have the same problem with my sz-serie... runtime error... and because of that I think my hotkeys don't work either :smileysad:

Reply
0 Kudos
Kurev
Visitor 2 Posts

Re: VAIO Control Center Broken!!

Today, exactly the same thing happened to my SZ-1. Bluetooth selection is not available anymore in the Wireless Device Switch tool, and also VAIO control centre fails to start with runtime error.

WDS has been working perfectly for BT so far, I didn't install any sw before before this happened. But just before this started to happen, I had to power down my laptop via long power key press, because Vista was stuck at shutdown screen. So maybe something went bad there, although I have had to do same powering down before too, and no problems has risen.

I have reinstalled WDS, control centre and bluetooth drivers, no help here. Bluetooth is constantly on now, and it is actually working too. But I'd really like to disable it when I do not use it, and now it is not possible. Of course it can be done via device manager, but that is not very fast nor nice.

If anyone has any ideas how to correct this, I'd be more than glad to hear them. I wouln't like to reinstall Vista just to get this working again. Thanks :smileyhappy:

Reply
0 Kudos
Kurev
Visitor 2 Posts

Re: VAIO Control Center Broken!!

I found out that control center gives runtime error when I try to run it from my administrator account, but when I use other standard account, it is working fine.

I wanted to check if wireless device switch is working too with standard account, but it does not start up at all. Not even when trying to run it as administrator.

Reply
0 Kudos